$re = '/(\" )(?:[\w])/';
$str = 'toto hector " Don\'t do that" " hello I am a boy" ';
$subst = "xxx";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;