using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\"" )(?:[\w])";
string substitution = @"xxx";
string input = @"toto hector "" Don't do that"" "" hello I am a boy"" ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}