use strict;
my $str = 'toto hector " Don\'t do that" " hello I am a boy" ';
my $regex = qr/(\" )(?:[\w])/p;
my $subst = 'xxx';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";