# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(score\[\\/.)(.*?)\](.*)/$3/g;t' <<< ";turnNumber[/N0];score[/N1];name[/S2];"