$re = '/(.*)(score\[\/.)(.*?)\](.*)/';
$str = ';turnNumber[/N0];score[/N1];name[/S2];';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;