const regex = /(.*)(score\[\/.)(.*?)\](.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(score\\[\\\/.)(.*?)\\](.*)', 'g')
const str = `;turnNumber[/N0];score[/N1];name[/S2];`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);