use strict;
my $str = ';turnNumber[/N0];score[/N1];name[/S2];';
my $regex = qr/(.*)(score\[\/.)(.*?)\](.*)/p;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";