// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)(score\[\/.)(.*?)\](.*)").unwrap();
let string = ";turnNumber[/N0];score[/N1];name[/S2];";
let substitution = "$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}