using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(score\[\/.)(.*?)\](.*)";
string substitution = @"$3";
string input = @";turnNumber[/N0];score[/N1];name[/S2];";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}