package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(score\[\/.)(.*?)\](.*)`)
var str = `;turnNumber[/N0];score[/N1];name[/S2];`
var substitution = "$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}