#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^/]+[.html]?)/?\?"
Local $sString = "https://www.somedomain/path/some-slug-94690" & @CRLF & _
"https://www.somedomain.com/one/somepath/another-slug?test" & @CRLF & _
"https://www.anotherdomain.com/somepath/another-slug/?test" & @CRLF & _
"https://www.anotherdomain.com/path/another_slug.html?test=true" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")