import re
regex = re.compile(r"([^/]+[.html]?)/?\?", flags=re.MULTILINE)
test_str = ("https://www.somedomain/path/some-slug-94690\n"
"https://www.somedomain.com/one/somepath/another-slug?test\n"
"https://www.anotherdomain.com/somepath/another-slug/?test\n"
"https://www.anotherdomain.com/path/another_slug.html?test=true\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")