using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^/]+[.html]?)/?\?";
string input = @"https://www.somedomain/path/some-slug-94690
https://www.somedomain.com/one/somepath/another-slug?test
https://www.anotherdomain.com/somepath/another-slug/?test
https://www.anotherdomain.com/path/another_slug.html?test=true
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}