$re = '`([^/]+[.html]?)/?\?`m';
$str = 'https://www.somedomain/path/some-slug-94690
https://www.somedomain.com/one/somepath/another-slug?test
https://www.anotherdomain.com/somepath/another-slug/?test
https://www.anotherdomain.com/path/another_slug.html?test=true
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);