package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^/]+[.html]?)/?\?`)
var str = `https://www.somedomain/path/some-slug-94690
https://www.somedomain.com/one/somepath/another-slug?test
https://www.anotherdomain.com/somepath/another-slug/?test
https://www.anotherdomain.com/path/another_slug.html?test=true
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}