re = /([^\/]+[.html]?)\/?\?/m
str = 'https://www.somedomain/path/some-slug-94690
https://www.somedomain.com/one/somepath/another-slug?test
https://www.anotherdomain.com/somepath/another-slug/?test
https://www.anotherdomain.com/path/another_slug.html?test=true
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end