use strict;
my $str = 'https://www.somedomain/path/some-slug-94690
https://www.somedomain.com/one/somepath/another-slug?test
https://www.anotherdomain.com/somepath/another-slug/?test
https://www.anotherdomain.com/path/another_slug.html?test=true
';
my $regex = qr`([^/]+[.html]?)/?\?`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}