using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<(contentplace)(\s+zone=""(\w+)"")?(\s+order=""(\d{1,5})"")?\s*\>(([\s|\S]*?)*?)\<\/\1>";
string input = @"<contentplace
zone=""top"">hgjgh jksdh</contentplace>
<contentplace zone=""bottom"">
asdasd
sadklsalkdsdk</contentplace>
</contentplace>
<contentplace zone=""left"" order=""1"">
<div>
match any charachters
</div>
</contentplace>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}