$re = '/\<(contentplace)(\s+zone="(\w+)")?(\s+order="(\d{1,5})")?\s*\>(([\s|\S]*?)*?)\<\/\1>/mi';
$str = '<contentplace
zone="top">hgjgh jksdh</contentplace>
<contentplace zone="bottom">
asdasd
sadklsalkdsdk</contentplace>
</contentplace>
<contentplace zone="left" order="1">
<div>
match any charachters
</div>
</contentplace>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);