import Foundation
let pattern = #"\<(contentplace)(\s+zone="(\w+)")?(\s+order="(\d{1,5})")?\s*\>(([\s|\S]*?)*?)\<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<contentplace
zone="top">hgjgh jksdh</contentplace>
<contentplace zone="bottom">
asdasd
sadklsalkdsdk</contentplace>
</contentplace>
<contentplace zone="left" order="1">
<div>
match any charachters
</div>
</contentplace>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)