use strict;
my $str = '<contentplace
zone="top">hgjgh jksdh</contentplace>
<contentplace zone="bottom">
asdasd
sadklsalkdsdk</contentplace>
</contentplace>
<contentplace zone="left" order="1">
<div>
match any charachters
</div>
</contentplace>';
my $regex = qr/\<(contentplace)(\s+zone="(\w+)")?(\s+order="(\d{1,5})")?\s*\>(([\s|\S]*?)*?)\<\/\1>/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}