import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<(contentplace)(\\s+zone=\"(\\w+)\")?(\\s+order=\"(\\d{1,5})\")?\\s*\\>(([\\s|\\S]*?)*?)\\<\\/\\1>";
final String string = "<contentplace\n"
+ " zone=\"top\">hgjgh jksdh</contentplace>\n\n"
+ "<contentplace zone=\"bottom\">\n"
+ "asdasd\n"
+ "sadklsalkdsdk</contentplace>\n"
+ "</contentplace>\n\n"
+ "<contentplace zone=\"left\" order=\"1\">\n"
+ "<div>\n"
+ " match any charachters\n"
+ "</div>\n"
+ "</contentplace>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}