#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+|\d{1,3}(?:\s?\d{3})*)(?:[.,](\d+))?$|^(\d+|\d{1,3}(?:[, ]?\d{3})*)(?:\.(\d+))?$|^(\d+|\d{1,3}(?:[. ]?\d{3})*)(?:\,(\d+))?$"
Local $sString = "4 294 967 295,000" & @CRLF & _
"4 294 967 295,000" & @CRLF & _
"4 294 967 295,000" & @CRLF & _
"4 294 967 295,000" & @CRLF & _
"4 294 967.295,000" & @CRLF & _
"4.294.967.295,000" & @CRLF & _
"4.294.967.295,000" & @CRLF & _
"4.294.967.295,000" & @CRLF & _
"4 294 967 295,000" & @CRLF & _
"4,294,967,295.00" & @CRLF & _
"4,294,967,295.00" & @CRLF & _
"4,294,967,295.00" & @CRLF & _
"4 294 967 295.000" & @CRLF & _
"4,294,967,295" & @CRLF & _
"4294967295.00" & @CRLF & _
"4294967295"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")