using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+|\d{1,3}(?:\s?\d{3})*)(?:[.,](\d+))?$|^(\d+|\d{1,3}(?:[, ]?\d{3})*)(?:\.(\d+))?$|^(\d+|\d{1,3}(?:[. ]?\d{3})*)(?:\,(\d+))?$";
string input = @"4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967.295,000
4.294.967.295,000
4.294.967.295,000
4.294.967.295,000
4 294 967 295,000
4,294,967,295.00
4,294,967,295.00
4,294,967,295.00
4 294 967 295.000
4,294,967,295
4294967295.00
4294967295";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}