use strict;
my $str = '4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967.295,000
4.294.967.295,000
4.294.967.295,000
4.294.967.295,000
4 294 967 295,000
4,294,967,295.00
4,294,967,295.00
4,294,967,295.00
4 294 967 295.000
4,294,967,295
4294967295.00
4294967295';
my $regex = qr/^(\d+|\d{1,3}(?:\s?\d{3})*)(?:[.,](\d+))?$|^(\d+|\d{1,3}(?:[, ]?\d{3})*)(?:\.(\d+))?$|^(\d+|\d{1,3}(?:[. ]?\d{3})*)(?:\,(\d+))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}