re = /^(\d+|\d{1,3}(?:\s?\d{3})*)(?:[.,](\d+))?$|^(\d+|\d{1,3}(?:[, ]?\d{3})*)(?:\.(\d+))?$|^(\d+|\d{1,3}(?:[. ]?\d{3})*)(?:\,(\d+))?$/m
str = '4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967.295,000
4.294.967.295,000
4.294.967.295,000
4.294.967.295,000
4 294 967 295,000
4,294,967,295.00
4,294,967,295.00
4,294,967,295.00
4 294 967 295.000
4,294,967,295
4294967295.00
4294967295'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end