const regex = new RegExp('^(\\d+|\\d{1,3}(?:\\s?\\d{3})*)(?:[.,](\\d+))?$|^(\\d+|\\d{1,3}(?:[, ]?\\d{3})*)(?:\\.(\\d+))?$|^(\\d+|\\d{1,3}(?:[. ]?\\d{3})*)(?:\\,(\\d+))?$', 'gm')
const str = `4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967.295,000
4.294.967.295,000
4.294.967.295,000
4.294.967.295,000
4 294 967 295,000
4,294,967,295.00
4,294,967,295.00
4,294,967,295.00
4 294 967 295.000
4,294,967,295
4294967295.00
4294967295`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}