import Foundation
let pattern = #"^(\d+|\d{1,3}(?:\s?\d{3})*)(?:[.,](\d+))?$|^(\d+|\d{1,3}(?:[, ]?\d{3})*)(?:\.(\d+))?$|^(\d+|\d{1,3}(?:[. ]?\d{3})*)(?:\,(\d+))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967 295,000
4 294 967.295,000
4.294.967.295,000
4.294.967.295,000
4.294.967.295,000
4 294 967 295,000
4,294,967,295.00
4,294,967,295.00
4,294,967,295.00
4 294 967 295.000
4,294,967,295
4294967295.00
4294967295
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)