import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+|\\d{1,3}(?:\\s?\\d{3})*)(?:[.,](\\d+))?$|^(\\d+|\\d{1,3}(?:[, ]?\\d{3})*)(?:\\.(\\d+))?$|^(\\d+|\\d{1,3}(?:[. ]?\\d{3})*)(?:\\,(\\d+))?$";
final String string = "4 294 967 295,000\n"
+ "4 294 967 295,000\n"
+ "4 294 967 295,000\n"
+ "4 294 967 295,000\n"
+ "4 294 967.295,000\n"
+ "4.294.967.295,000\n"
+ "4.294.967.295,000\n"
+ "4.294.967.295,000\n"
+ "4 294 967 295,000\n"
+ "4,294,967,295.00\n"
+ "4,294,967,295.00\n"
+ "4,294,967,295.00\n"
+ "4 294 967 295.000\n"
+ "4,294,967,295\n"
+ "4294967295.00\n"
+ "4294967295";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}