#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\/\n]+\/1\/[^\/\n]+\/temperature$"
Local $sString = "home/1/bedroom/temperature" & @CRLF & _
"/1//temperature" & @CRLF & _
"home/1/bedroom/2/temperature" & @CRLF & _
"home/upstairs/1/bedroom/temperature"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")