package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\/\n]+\/1\/[^\/\n]+\/temperature$`)
var str = `home/1/bedroom/temperature
/1//temperature
home/1/bedroom/2/temperature
home/upstairs/1/bedroom/temperature`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}