// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\/\n]+\/1\/[^\/\n]+\/temperature$").unwrap();
let string = "home/1/bedroom/temperature
/1//temperature
home/1/bedroom/2/temperature
home/upstairs/1/bedroom/temperature";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}