using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\/\n]+\/1\/[^\/\n]+\/temperature$";
string input = @"home/1/bedroom/temperature
/1//temperature
home/1/bedroom/2/temperature
home/upstairs/1/bedroom/temperature";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}