import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\/\\n]+\\/1\\/[^\\/\\n]+\\/temperature$";
final String string = "home/1/bedroom/temperature\n"
+ "/1//temperature\n"
+ "home/1/bedroom/2/temperature\n"
+ "home/upstairs/1/bedroom/temperature";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}