re = /^[^\/\n]+\/1\/[^\/\n]+\/temperature$/m
str = 'home/1/bedroom/temperature
/1//temperature
home/1/bedroom/2/temperature
home/upstairs/1/bedroom/temperature'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end