$re = '/^[^\/\n]+\/1\/[^\/\n]+\/temperature$/m';
$str = 'home/1/bedroom/temperature
/1//temperature
home/1/bedroom/2/temperature
home/upstairs/1/bedroom/temperature';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);