#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(^[1-9]\d*)(\.\d*[1-9])?|(^0)(\.\d*[1-9]))([eE][+-](?!0+$)\d+)?$"
Local $sString = "123.4021203" & @CRLF & _
"0.11" & @CRLF & _
"00023123.1230000" & @CRLF & _
"0.101010101023e-124" & @CRLF & _
"010.000001" & @CRLF & _
"1230.123e+123" & @CRLF & _
"0.1e-1" & @CRLF & _
"1e-1" & @CRLF & _
"0e+2" & @CRLF & _
"0.e+2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")