using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(^[1-9]\d*)(\.\d*[1-9])?|(^0)(\.\d*[1-9]))([eE][+-](?!0+$)\d+)?$";
string input = @"123.4021203
0.11
00023123.1230000
0.101010101023e-124
010.000001
1230.123e+123
0.1e-1
1e-1
0e+2
0.e+2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}