re = /(?:(^[1-9]\d*)(\.\d*[1-9])?|(^0)(\.\d*[1-9]))([eE][+-](?!0+$)\d+)?$/m
str = '123.4021203
0.11
00023123.1230000
0.101010101023e-124
010.000001
1230.123e+123
0.1e-1
1e-1
0e+2
0.e+2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end