import re
regex = re.compile(r"(?:(^[1-9]\d*)(\.\d*[1-9])?|(^0)(\.\d*[1-9]))([eE][+-](?!0+$)\d+)?$", flags=re.MULTILINE)
test_str = ("123.4021203\n"
"0.11\n"
"00023123.1230000\n"
"0.101010101023e-124\n"
"010.000001\n"
"1230.123e+123\n"
"0.1e-1\n"
"1e-1\n"
"0e+2\n"
"0.e+2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")