import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(^[1-9]\\d*)(\\.\\d*[1-9])?|(^0)(\\.\\d*[1-9]))([eE][+-](?!0+$)\\d+)?$";
final String string = "123.4021203\n"
+ "0.11\n"
+ "00023123.1230000\n"
+ "0.101010101023e-124\n"
+ "010.000001\n"
+ "1230.123e+123\n"
+ "0.1e-1\n"
+ "1e-1\n"
+ "0e+2\n"
+ "0.e+2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}