$re = '/(?:(^[1-9]\d*)(\.\d*[1-9])?|(^0)(\.\d*[1-9]))([eE][+-](?!0+$)\d+)?$/m';
$str = '123.4021203
0.11
00023123.1230000
0.101010101023e-124
010.000001
1230.123e+123
0.1e-1
1e-1
0e+2
0.e+2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);