#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\/|$)"
Local $sString = "http://example.com/somepath/this-is-composed-of-hypens-3144/someotherpath"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")