using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\/|$)";
string input = @"http://example.com/somepath/this-is-composed-of-hypens-3144/someotherpath";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}