package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\/|$)`)
var str = `http://example.com/somepath/this-is-composed-of-hypens-3144/someotherpath`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}