re = /\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\/|$)/i
str = 'http://example.com/somepath/this-is-composed-of-hypens-3144/someotherpath'
# Print the match result
str.match(re) do |match|
puts match.to_s
end