const regex = /\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\/|$)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\\\/|$)', 'i')
const str = `http://example.com/somepath/this-is-composed-of-hypens-3144/someotherpath`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}