$re = '/\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\/|$)/i';
$str = 'http://example.com/somepath/this-is-composed-of-hypens-3144/someotherpath';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);