#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?six)\b(?:[a-z](?:[a-z\n\r.:;,?!-]*[a-z])?)\b"
Local $sString = "How do I match text with a regular expres" & @CRLF & _
"sion ignoring punctuation and line breaks?" & @CRLF & _
"How do I do "find these words pos-" & @CRLF & _
"sibly separated but some non-alphanumeric characters"?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")