package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?six)\b(?:[a-z](?:[a-z\n\r.:;,?!-]*[a-z])?)\b`)
var str = `How do I match text with a regular expres
sion ignoring punctuation and line breaks?
How do I do "find these words pos-
sibly separated but some non-alphanumeric characters"?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}